TechWeb

iPhone Hackers Jailbreak OS 3.0 Software

Jun 26, 2009 (11:06 AM EDT)

Read the Original Article at http://www.informationweek.com/news/showArticle.jhtml?articleID=218101606


The iPhone Dev Team is at it again, and the group of hackers has released software that enables iPhone 3.0 users to install non-App Store programs on their device.

This software is called Ultrasn0w, and it "jailbreaks" the device by removing Apple's software controls that prohibit independent applications from being installed. The Dev Team is also responsible for creating software that enables iPhone owners to unlock the handset and take it to any GSM carrier.

It is unclear if this software will gain a wide audience because many of the original advantages to a jailbroken device have faded away. Users could unlock the iPhone to use T-Mobile's service, but the iPhone 3G wouldn't be able to access the network's 3G network because the smartphone is not designed for T-Mobile's spectrum.

Users will be able to find a wider variety of apps with the jailbreak software though, as developers won't have to pass Apple's relatively-strict vetting process. This means users will be able to download live-streaming apps like Qik, as well as download apps that can run in the background.

But the appeal of these non-approved apps may be waning, as the 3.0 firmware gives developers more than 1,000 new hooks into the hardware. While there are a few alternative iPhone app stores, most developers will look at the App Store as the main means of distribution because it has an audience of more than 40 million iPhone and iPod Touch users.

The jailbreaking and unlocking software do not currently work with the iPhone 3GS, the Dev Team said. The group said the software should be available soon because the touch-screen smartphone is vulnerable to an exploit that is present in the second-generation iPod Touch.

The iPhone may be your next full-function computer. InformationWeek has published an independent analysis of this topic. Download the report here (registration required).