Feb 25, 2003 (07:02 PM EST)
Security Firm Says Nokia 6210 Mobile Phones Vulnerable To Attack

Read the Original Article at InformationWeek

Security firm @stake says Nokia 6210 cellular phones are vulnerable to a denial-of-service attack. According to an advisory issued late Wednesday, @stake says an attacker could send a maliciously designed vCard, commonly used to exchange address and contact information, to a handset, causing it to automatically lock up or freeze. To restart the handset, the user must remove and replace the battery.

While the attack may not be damaging, it does highlight an anticipated trend: As PDAs and cell phones gain more functionality, the security problems that plaque IT systems will shortly follow. "This is a good example of why all newly introduced product functionality should be reviewed to ensure that no new security vulnerabilities will also be introduced," wrote Ollie Whitehouse, director of security architecture at @stake, in the advisory. "A cursory source-code audit would find an error of this type."

While Nokia couldn't be immediately reached for comment, the phone maker did respond to @stake, saying the error affects only the Nokia 6210 with version 05.27 or higher software. Nokia says the possibility of users experiencing this error is remote, as it would depend on an attacker's ability to create and send malformed business cards over the air to the mobile phone. Nokia also added that "it is very simple to deal with the error," as the user only needs to restart the phone by removing the battery, and there's no damage caused to the phone memory. At this time, Nokia has no plans "to issue a software fix for this error caused by an intentional action of a person."