Mar 30, 2003 (07:03 PM EST)
New Sendmail Vulnerability

Read the Original Article at InformationWeek

The information security clearinghouse CERT Coordination Center is warning of another serious security flaw in the popular Sendmail E-mail server software.

According to CERT, vulnerable versions of Sendmail can give attackers "root" access to a company's Sendmail servers. From there, attackers can run any of the company's applications or open the servers up to denial-of-service attacks.

Vulnerable Sendmail apps include all Sendmail Pro and open-source Sendmail versions prior to 8.12.8, including Unix and Linux versions. Several versions of Sendmail Switch and Sendmail for Windows NT also are vulnerable, according to CERT.

This Sendmail problem is unrelated to one discovered by Internet Security Systems Inc. and revealed in early March. The trouble occurs in the way Sendmail fails to adequately check the length of E-mail addresses, a situation referred to as "stack overflow," which enablers an attacker to gain control of a server.

Sendmail is widely used by midsize and large businesses, and CERT says most companies probably have vulnerable servers in operation. Even if a company is using another E-mail server at its gateway, properly designed E-mails could be forwarded to vulnerable internal Sendmail servers and cause trouble. To make matters more frustrating for admins, many Unix and Linux workstations contain an implementation of Sendmail that's enabled by default.

CERT's advisory, CA-2003-12, is available on its Web site. For additional information, see www.sendmail.org and www.sendmail.com/security.