Nov 28, 2007 (02:11 PM EST)
IBM Warns Of Lotus Notes Vulnerability

Read the Original Article at InformationWeek

IBM on Tuesday issued a security advisory for its Lotus Notes corporate e-mail software. It warned that an attacker could exploit a flawed third-party component and execute malicious code on the victim's PC.

"To successfully exploit this vulnerability, an attacker would need to send a specially crafted Lotus 1-2-3 file attachment to users, and the users would then have to double-click and view the attachment," the advisory reads.

The vulnerability was reported to IBM by Core Security, which posted details on its Web site. In order to view and process Lotus Worksheet File format (WKS) attachments, Lotus Notes relies on Autonomy's Verity KeyView SDK, which contains several buffer overflow vulnerabilities.

"Although these specific vulnerabilities exist on a third"party component the problem is compound by the way Lotus Notes displays information about attachments, making it easier to elicit unsuspecting assistance from the users to exploit them," Core Security's advisory warns.

This is because Lotus Notes displays an icon associated with the attached file's extension rather than its MIME Content-Type header. An attacker could take advantage of this feature in order to conceal the true nature of a malicious file.

IBM said the vulnerable versions of Lotus Notes include 6.0, 6.5, 7.0, and 8.0. "There is no software fix available for the Notes 5.x client version," the company said.

IBM provides instructions for disabling the affected file viewing software in its advisory.

"This is a severe threat to organizations that use Lotus Notes for corporate e-mail communications," said Ivan Arce, CTO at Core Security Technologies, in a statement.